Fujitsu Siemens Amilo pa1510 + Ubuntu 14.04

Mein alter Fujitsu Siemens Amilo pa1510 ist mittlerweile sieben Jahre alt, funktioniert aber immer noch ganz ordentlich. Aber es war mal an der Zeit für ein Facelifting. Damit alles etwas leichtgewichtiger wird, läuft er jetzt mit Xubuntu 14.04 Trusty Tahr.
Es läuft alles ganz prima, nur der mittlerweile vier Jahre alte Bug bei der Ansteuerung des Atheros 2413 ist immer noch da. Aber da er sich leicht beheben ließ, stellte er kein wirkliches Problem dar.

Jetzt bin ich neugierig, wie lange die Kiste noch durchhält.

Wie dämlich …

Seit vier Jahren habe ich jetzt meinen Amilo PA1510 Notebook in Betrieb. Ein geradezu antiquarisches Ding, aber es funktioniert. Vor ein paar Wochen dann fiel mir auf, dass das Notebook ständig bei 800MHz arbeitet. Es ließ sich durch nichts dazu bewegen schneller zu werden. Die maximale Geschwindigkeit der beiden CPUs von 1.6 GHz wurde zwar erkannt (ok, auch nicht gerade atemberaubend schnell), aber der Scaling Governor ließ einfach keine höhere Geschwindigkeit zu.
Alles Gegoogle und Gebastele half nicht. Bis ich eben die Lösung fand: im BIOS war eingestellt, dass der Rechner die Lebensdauer der Batterie schonen sollte. Das tat er offensichtlich dadurch, dass die maximale Frequenz heruntergesetzt wurde. Denn kaum war die Einstellung geändert, lief auch wieder alles richtig.

Wie dämlich….

Atheros 2413 und Ubuntu 10.04

Nach drei Jahren war es mal an der Zeit, dass ich meinen Amilo PA 1510 mal komplett neu aufsetze. Das ging auch ohne Probleme, nur die WLAN-Verbindung verhielt sich merkwürdig. So war der Browser nicht benutzbar, da er meist schon beim Laden des ersten Files einer Seite hängenbleibt. Die Lösung fand sich im Launchpad als Bug 568090: ein paar Parameter für die Treiberinitalisierung. Am Einfachsten geht das so:


sudo sh -c "echo 'options ath5k nohwcrypt' >/etc/modprobe.d/custom-wireless.conf"

ATI Radeon und Hibernate unter Gutsy

Das Update auf Gutsy hatte einen ärgerlichen Seiteneffekt bei meinem Amilo Pa 1510: Suspend und Hibernate funktionierten nicht mehr. Das Problem liegt in einer Änderung im Kernel 2.6.22/23, der einen Fehler im propritären ATI-Treiber auslöste. Eine Möglichkeit das Problem zu lösen ist einen eigenen Kernel zu compiliereren uns statt SLUB SLAB zu benutzen. Die Kernel-Compilierungszeiten sind bei mir vorbei; ich warte lieber ein paar Wochen. Und siehe da im Unofficial ATI Linux Driver Wiki stand die Lösung. Also schnell den Express 1350 (Bereich „Integrated/Motherboard) (Express 1100 gibt es nicht von ATI) heruntergeladen und installiert. Und siehe da: es funktioniert wieder.
Die 3D Möglichkeiten habe ich allerdings noch nicht ausprobiert.

Der mutige Gibbon

Gestern Nacht hat sich auf meinem Notebook das lebhafte Rehkitz (Feisty Fawn) in einen mutigen Gibbon (Gutsy Gibbon) verwandelt. Ohne Probleme.
Falls jemand nicht weiss wovon ich spreche: es geht um das automatische Upgrade der Ubuntu Linux Distribution auf meinem Notebook.
So, und jetzt ist mein Arbeitsplatzrechner dran.

Nachtrag:25.10.2007
Suspend und Sleep wollen nicht mehr. Hm….